Bug / request re: "Sort by page order"

When working in Study mode on Note files, within the Outline view, it seems that MarginNote creates a default parent (or indented note) of the Note title, and then the annotations become children that fall under that Note-title parent.

It also seems that subsequent user annotations are organized and displayed, by default, in “Sort by create date” (i.e., the order that they were made); not “Sort by page order” (i.e., where they actually exist in the order of a given file).

I’ve found this problematic for various reasons, and so I have to regularly select all annotated notes in the Outline view, and then select “Sort by page order.” But every time I do so, I have to first de-selection the Note-title parent and delete it so that it doesn’t disorder the annotated notes.

I understand that the Note-title parent is used to group all of the annotated notes that fall beneath it when a MarginNote notebook contains two or more documents. That’s reasonable. Still, I feel that @marginnote (or @Relight_Support-Team) should consider a way to fix the way that users can:

  • Select “Sort by page order” as a default option under preferences (and/or select Documents / Notes) and

  • Provide a way that Note-title parents don’t reappear each time users create new annotations – especially after deleting Note-title parents the first time. Again, I recognize the organizational utility of such Note-title parents, but find them to be troublesome when trying to simply order my notes by “Sort by page order”

Thank you for considering this request.

1 Like

Hello, JournoProf,

Really thanks for the information provided. As I usually just use mindmap to organize my thoughts, it does take me some time to understand your requests.

I agree with you and think it’s a good idea for users who choose Outline as a learning tool.

Sincerely,
Bryan

1 Like

I’ve had the same exact problem, actually. I didn’t actually realize that MarginNote’s Study mode was creating these kinds of “Note-title parents” until @JournoProf point that out here… Thanks so much! That helps clarify quite a few things with why I’ve been seeing (and deleting) all of these indented notes with disclosure triangles all of my documents!

In fact, earlier this year I wrote @Kevin_Support-Team (or @Relight_Support-Team / @Lanco_Support-Team) about the problems I was having not being able to “Sort by page order” in MarginNote Notes.

I’m happy to say that @marginnote fixed this problem! (Well, it was still a bit glitchy, especially with larger documents.) Still, credit where credit is due…

Anyway, I think that @JournoProf nails the solution in his two suggested bullet points, and I hope that @marginnote can make those changes. If nothing else, “Sort by page order” should be the default setting for MarginNote Notes (in the Outline view). That’s a no brainer.

Thanks!

1 Like

I am in full agreement with @jprint’s assessment here.

1 Like