How to stop Auto Locate when editing excerpts in the MindMap?

Currently, I have all the Auto Locate settings turned off (e.g. Auto Locate Document, Auto Locate MindMap, and Auto Locate Current Note in Other Windows). However, whenever I edit an excerpt in the MindMap, it auto locates the location of that excerpt in the document and I lose my place in the document.

If I switch to Outline view and edit the excerpt from the Outline, this doesn’t happen. Is there any way to turn off the Auto Locate when editing in MindMap view as well?

Hello, would you be able to upload some screenshots or videos describing it in detail? That way I can help you better.

Thanks for the response. I realized later that double tapping on the excerpt text to edit in the MindMap does not result in Auto Locate. The Auto Locate only happens when I click on the edit button for the excerpt (from the screenshot).