iPad and MacOs iCloud out of sync

I am using the latest version of MN3 on both iPad and MacOS.

My iPad and my MacOS both say they are in sync with iCloud - yet, I have documents in sub-folders in my iPad (with changes) that are not showing up in my MacOS.

I have tried to get them to MacOS in the following ways:

  • Refreshing and re-syncing
  • Turning iCloud sync on and off for the specific documents that aren’t showing up
  • Making changes to the document on the iPad and re-syncing (it said it was successful, but still doesn’t show up on MacOS)
  • Closing & re-opening both iPad and MacOS version
  • “Delete from device” on MacOS, and then “Download from Cloud Sync | Doc Notebook”.
  • Confirmed that the PDF files themselves do appear in the iCloud folder (so that part of the syncing is working).

This is how I seemed to be able to fix it:

  • Moved them from the sub-folder to the root folder on the iPad, they now showed up on the MacOS, but they don’t have a cloud icon.
  • Moved them back from the root folder to the sub-folder on the iPad, they didn’t get removed from the root folder on the MacOS, and still don’t show up in the sub-folder.
  • Moved them from the root folder to the sub-folder on the MacOs, and they now appear in the folder with the cloud icon, and changes are now syncing.

It appears the database got out of sync with iCloud, and force moving the files around on both platforms forced it to get back in sync.

[NOTE: I’ve done a full backup, just in case].


we will soon pass the latest version “mn4” at that time you can try the icloud sync , it may solve your problem

Kind Regards,

Support Team