Video Flashcards not working when exported to Anki

The video does not play in Anki when I click on it. Please help.

I downgraded to Anki 2.0 and it worked. It seems the issue is with Anki 2.1 and MP4 format.

Hi sbsb,

Third parties’s compatibility with marginote may be lowered owing to upgrades of these apps(e.g.Format changes). Anyway,we will carry on our work on development to get with it in time.

Best Regards,
Lanco
MN Support Team

@Lanco-MN_Support Could we have a way to exclude the videos when exporting to anki? It’s creating huge apkg files (200MB+ in my case) and the export process took several minutes. To me the most valuable part for a exported-to-anki card is the clozes I created out of them. If I want to watch the video, I can just click the link in anki and it would bright me back to proper location in MN.

@lins05 What’s your device? On my mac, this process is fast. Maybe its limited by performance. It is suggested to use MN Review when you have Video in your cards.

Currently customized export is not supported by MN (Only some preset option could be chosen). But we have a plan to support an Extension Platform in MN 4.0 with lots of data API. You could write your own customized export Extension.

By the way, video decoder is Apple system built-in. Some format may not supported well.

Kind Regards,
Lanco
Support Team

I have latest RMBP 15’ with 8-core i9 CPU and 32GB ram.

I guess you don’t have many video excerpts. I have about ten of them so I guess the time is spent on splitting the videos excerpts to standalone mp4 files when exporting.

How about OmniOutliner integration? Please test oo3 files export time spending to see whether the issues related to files format.

I tested export to iThoughtsX and it works very fast.

Ok, thank you! We will try to fix it.

1 Like