When auto add is turned off and selected position is turned on, iPad has different (preferred) behaviour than Mac (broken, IMO)

In Study mode If you have Auto Add to Mindmap turned off then Auto Insertion Position>Selected Position behaves differently on iPad and Mac. I definitely prefer the iPad behaviour and, in fact, had written a bug report on the Mac behaviour before I noticed that iPad worked correctly.

On the iPad, if I have a node selected and the above conditions are true, when I Add to Mindmap with a newly selected excerpt it creates the new node as a sibling. On the Mac it creates the new node as floating.

I notice on the Mac that it deselects a node that is selected when I highlight text as a new excerpt, I can only think you are trying to avoid confusion about a node being selected that doesn’t match the current text selection. Unfortunately this causes the Mac version to not know where to place the new node.

I don’t know how to resolve the confusion I just referred to, however I do know the iPad works correctly and there hasn’t been any such confusion. I don’t have the time to think it through completely but that’s kind of your job anyway :slight_smile:

If this isn’t clear I can upload vid but it will need a few hours before I have the time.

Sorry for the late reply.
Are you sure that your settings for the auto insertion position between iPad and Mac are the same? Because on my side, if two settings are the same, they work perfectly consistently.

In 3.7.4 the the iMac and the iPad were behaving inconsistently. In 3.7.5 they now both behave the same.

At any rate, they are now both sort of broken. Auto Insertion Position set to Selected Position doesn’t work unless Auto Add to MindMap is turned on.

This used to work fine on iPad (in 3.7.4). I understand that you can justify it behaving the way it does, but it certainly is not expected nor desired behaviour when working with documents that you don’t want to auto add every highlight into the mind map.

Particularly since there is no way to remove a node without also affecting the highlight.


Yes I also have this problem - should be a bug.

I have reported this to our developer team, thank you for your sincere advice!

Sorry for the inconvenience.

Kind Regards,
Support Team