MarginNote 3.7.2005 crashes repeatedly

I just upgraded to MN 3.7.2005 on macOS.

Every time I try to open study mode, MN crashes. I am not offered the option of submitting a bug report.

Please advise.

Also, I would appreciate a reply to these posts:


Hmm, I know it doesn’t help but on two macs here across 9 studies, some more complex than others, I’m not seeing this after updating to 3.7.2005.

Have you tried creating a new study? Have you tried more than one study? If it’s a particular study then support will likely as you to send the file to them.

If it is a particular study can you restore from a backup? I make backups of my entire marginnote projects once every half hour when I’m working hard because, well, I don’t trust it entirely :slight_smile:

I haven’t tried creating a new study. If I can’t open my existing studies (I have tried several different ones), then basically I’m stuck.

Five or ten minutes after MN crashed, an alert box popped up to ask if I want to send a message to Apple.

How do you make backups?

Just be aware the backups are everything so they get large. I periodically remove older backups.

I do feel your pain here. I’d be panicking if this were happening to me. Just some thoughts though they may or may not be helpful.

*Do all of your studies share the same document(s). If so, I’d figure out which documents are shared with all of them and then create a new study with one document at a time from that shared document list to isolate which of the documents might be causing the crash.

This won’t solve YOUR problem but if @Sushi_Support-Team has less to work with then they might find a solution faster.

Does the crash happen as soon as the mind map appears on the screen? Do you see any data at all before it crashes? Sometimes this can help to identify precisely what is causing the problem.

Also, try removing the app completely from your computer and then reinstalling it. I honestly don’t know where marginnote keeps its data, however, so I’d make a backup first of everything.

Also, if you are using the direct download version (not mac app store) have your activation key at hand and deactivate the current install first. I am not certain this is necessary but I would do it just to be cautious.

I can’t think of anything else right now but if I remember any other tips I’ll add them to the post. Hopefully we can get you in the clear!

Thanks for the tips.

Does the crash happen as soon as the mind map appears on the screen? Do you see any data at all before it crashes?

The crashes are happening with different PDFs and different studies. When I open a study, there’s the usual spinning “wait cursor” that appears as the mind map is being constructed, and the app crashes right at that moment, before the mind map actually appears.

I haven’t tried reinstalling the app. It seems like that shouldn’t be necessary, and I don’t want to get into problems with activation.

Regarding actual data, MN uses a standard SQLite database, that is stored in ~/Library/Containers/QReader.MarginStudyMac/Data/Library/Application Support/QReader.MarginNoteMac/MarginNotes.sqlite. All your notes and mind maps are stored in there, I believe. The PDFs are copied to ~/Library/Containers/QReader.MarginStudyMac/Data/Documents.

Sometimes the obvious ones…have you tried just restarting your mac?

And thanks for the location of the data. I went looking in Application Support :stuck_out_tongue:


Sorry for the problem. You can try download MarginNote from the link below.

Also, in case this does not work, may I know your device information, system version, and have a crash log of the software? (You can access the crash log in the console app.)

Sorry again for the inconvenience.

Kind Regards,
Support Team


Thanks. I downloaded that link (MN 3.7.2008) and it works. I launched the app from the /Download directory.

Question: should I drag it to the /Applications directory and overwrite the older one (3.7.2005)?

P.S. I’m on a MBP (Retina, 13", mid-2014), with 16 GB DRAM, running macOS 10.13.6.

@mobo I dragged it from the downloads folder to the applications folder, overwriting the existing application and it opens fine with no licensing issues. Just fyi.


Oh yeah, you should. Sorry for the late reply.

Kind Regards,
Support Team

It works. Thanks. problem solved.


You are welcome~

Kind Regards,
Support Team