Notes format is lost

I have tried applying both italics (via Macos/Marginnote Format menu at the top, and a monotype style (via double clicking the text, right clicking and selecting Format/Styles) to the notes/highlights I’ve in a mindmap. MN applies the formatting while the text is selected, but once I finish changing the format and clicking elsewhere, the format is lost.

It doesn’t happen with bold, but it’s the only format I’ve been able to keep. Is this a bug or is it me missing something?

Hello

Would you be able to upload some screenshots or videos describing it in detail? That way I can help you better.

Kind Regards,
MarginNote-Edward
Support Team

It’s a bug. Users have been asking about the lack of italics support for a long time (e.g., see: Feature Request - Additional Emphasise Mode Should Feature In Note Card's), then it was sort of fixed, but not really. It has since been fixed more in a preview version of MN (3.6.16003). I’ve tried the preview, and it seems to work, though I don’t know when the fix will be released.

Note that even in the fixed version (MN 3.6.16003), there is a shortcut key for bold (Cmd-B), but no shortcut key for italic emphasis (Cmd-I).

I hope that a shortcut key for italics will be added when this fix is finally released.

@Support-Team, thanks a lot for answering, but I’ve just recorded and posted a video of a much crucial problem. That problem (posted here ) makes this one totally unimportant. I’ve learnt to leave without using italics or any other format in MN notes… Will record a video too when I have more time though, maybe once I see I can work with MN, which I’d love to…

Good to know @Mobo, thanks…